Fix that pesky Bash ShellShock vulnerability on Centos CVE-2014-6271, CVE-2014-7169

If you have a Linux server running Centos you may well be vulnerable to the Bourne Again Shell (bash) shell shock vulnerability. This vulnerability is considered critical and needs to be fixed sharpish.

To check if your server is affected run the following command (taken from RedHat):


env x='() { :;}; echo vulnerable' bash -c "echo this is a test"

if it returns “vulnerable” then it needs a patch

so you type


yum update bash

which should fix the problem to test run the command again and you should see this time it won’t return “vulnerable”

Comments are closed.